Back to overview
Downtime

Logs dashboard is unavailable to EU customers

Jan 31 at 07:59am UTC
Affected services
Logs & Metrics

Resolved
Jan 31 at 08:09am UTC

The network router has been successfully replaced by our server housing provider, the services should be back up. Need help? Please let us know at hello@betterstack.com. We're sincerely sorry for the inconvenience.

Created
Jan 31 at 07:59am UTC

We were notified that our server housing provider registered a hardware issue with their networking equipment. They're working hard on resolving it.